Microsoft Excel:

  Таблицы и VBA. Справочник.
  Вопросы и Ответы. Советы. Примеры.
Меню FAQ | Ввод данных


Rambler's Top100


Counter CO.KZ

    [1] [1/2] [2] [3]

    Ввод, редактирование данных [2]
  1. Как обойти ограничение на ввод не более 255 символов в ячейку ? 2004
  2. Как сделать, чтобы в текстовом поле отображался результат из ячейки ? 2004
  3. Как сравнить два числа, если одно из них представлено в виде текста ? 22.03.2007
    [1] [1/2] [2] [3]


  • Ответ : Актуально для MS Excel 95
    Никак, но Вы можете воспользоваться для этого текстовым полем, которое допускает ввод более 1000 символов.
    Для создания текстового поля необходимо в меню Вид выберите пункт Панели инструментов, далее команду Рисование. На стандартной панели инструментов найдите кнопку с подписью Надпись (примерно посередине панели). Щёлкните по ней левой кнопкой мышки и выберите место для расположения надписи, далее опять щёлкните левой кнопкой мышки. После чего Вы можете ввести текст.
    Примечание : С текстовым полем можно обращаться также как с любым графическим об'ектом (менять размеры, шрифт и т.д.)
  • Ответ :
    Выделите текстовое поле.
    Вариант I. Щёлкните на строку формул.
    Вариант II. Нажмите клавишу F2.
    Введите знак равно (=) и выделите ячейку, результат которой Вам необходимо видеть в текстовом поле, затем нажмите ENTER.
  • Ответ :
    Данный способ сравнения будет возвращать корректный, с точки зрения поставленной задачи [1], результат, если :
    - любое из чисел будет представлено в виде текста
    - оба "числа" будут представлены в виде текста
    - оба сравниваемых значения будут представлены в виде чисел

    =СОВПАД(1;"1")
    =СОВПАД(A2;"1")
    =СОВПАД(A2;B2)


    или

    =СЧЁТЕСЛИ(A2;"1")=1
    =СЧЁТЕСЛИ(A2;B2)=1

    Воспроизведение любых опубликованных здесь материалов возможно только с письменного разрешения автора : Microsoft Excel 95, 97, 2000, XP

  • © 2004-2016 Климов П.Ю. Все права защищены. WebDesign & Error's Klimoff